using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Application Name:)[^\n]*(?=[^=]*(?=Secret Key))";
string input = @"Application Details for the XYZ application:
=========================================================
Application Name: XYXZW
Application Id: XYZ353WERX
Secret Key: XYZ86JBHHSD
Application Details for the XYZ application:
=========================================================
Application Name: XYXZW
Application Id: XYZ353WERX
Application Details for the XYZ application:
=========================================================
Application Name: XYXZW
Application Id: XYZ353WERX
Secret Key: XYZ86JBHHSD
Application Details for the XYZ application:
=========================================================
Application Name: XYXZW
Application Id: XYZ353WERX";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}