const regex = /(\blike\b|\beat\b)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\blike\\b|\\beat\\b)', 'g')
const str = ` TEXT
I like to eat cheetos.
There is a snake in my boots
to eat is to like food
The sun stopped setting, Rlyah Cthullhu!
Treat yourself!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}