$re = '/(\blike\b|\beat\b)/';
$str = ' TEXT
I like to eat cheetos.
There is a snake in my boots
to eat is to like food
The sun stopped setting, Rlyah Cthullhu!
Treat yourself!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);