re = /(\blike\b|\beat\b)/
str = ' TEXT
I like to eat cheetos.
There is a snake in my boots
to eat is to like food
The sun stopped setting, Rlyah Cthullhu!
Treat yourself!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end