// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\blike\b|\beat\b)").unwrap();
let string = " TEXT
I like to eat cheetos.
There is a snake in my boots
to eat is to like food
The sun stopped setting, Rlyah Cthullhu!
Treat yourself!";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}