#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\d{1,3}[. ]\d{1,3}[. ]\d{1,3}[. ]\d{1,3}$"
Local $sString = "192.168.10.111-" & @CRLF & _
"192.168.10.111"
Local $sSubst = "X.X.X.X"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)