// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{1,3}[. ]\d{1,3}[. ]\d{1,3}[. ]\d{1,3}$").unwrap();
let string = "192.168.10.111-
192.168.10.111";
let substitution = "X.X.X.X";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}