using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{1,3}[. ]\d{1,3}[. ]\d{1,3}[. ]\d{1,3}$";
string substitution = @"X.X.X.X";
string input = @"192.168.10.111-
192.168.10.111";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}