re = /^\d{1,3}[. ]\d{1,3}[. ]\d{1,3}[. ]\d{1,3}$/m
str = '192.168.10.111-
192.168.10.111'
subst = 'X.X.X.X'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result