using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=)\d+_\d+(?=)";
string input = @"123_4,56776_17,_,99997_1,_,87969_3,_,_,_,_,_,_,_,456_9";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}