$re = '/(?<=)\d+_\d+(?=)/';
$str = '123_4,56776_17,_,99997_1,_,87969_3,_,_,_,_,_,_,_,456_9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);