const regex = /(?<=)\d+_\d+(?=)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=)\\d+_\\d+(?=)', 'g')
const str = `123_4,56776_17,_,99997_1,_,87969_3,_,_,_,_,_,_,_,456_9`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}