re = /(?<=)\d+_\d+(?=)/
str = '123_4,56776_17,_,99997_1,_,87969_3,_,_,_,_,_,_,_,456_9'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end