import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[$£€](?:\\d{1,3},)*\\d{1,3}(?:\\.\\d+)?|(?:\\d{1,3},)*\\d{1,3}(?:\\.\\d+)?[$£€]$";
final String string = "$2\n"
+ "2$\n"
+ "€2,000\n"
+ "2,000€\n"
+ "£3,000,000.15\n"
+ "3,000,000.15£";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}