$re = '/^[$£€](?:\d{1,3},)*\d{1,3}(?:\.\d+)?|(?:\d{1,3},)*\d{1,3}(?:\.\d+)?[$£€]$/m';
$str = '$2
2$
€2,000
2,000€
£3,000,000.15
3,000,000.15£';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);