import re
regex = re.compile(r"^[$£€](?:\d{1,3},)*\d{1,3}(?:\.\d+)?|(?:\d{1,3},)*\d{1,3}(?:\.\d+)?[$£€]$", flags=re.MULTILINE)
test_str = ("$2\n"
"2$\n"
"€2,000\n"
"2,000€\n"
"£3,000,000.15\n"
"3,000,000.15£")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")