#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "vars\/(prod\S*|stage\S*)\/(mysql|keys).yml"
Local $sString = "vars/prod-region1/mysql.yml" & @CRLF & _
"vars/prod-region1/keys.yml" & @CRLF & _
"vars/prod-region1/test.yml" & @CRLF & _
"vars/stage-region2/mysql.yml" & @CRLF & _
"vars/stage-region2/keys.yml" & @CRLF & _
"vars/stage-region2/test.yml" & @CRLF & _
"vars/local/mysql.yml" & @CRLF & _
"vars/local/test.yml"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")