using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"vars\/(prod\S*|stage\S*)\/(mysql|keys).yml";
string input = @"vars/prod-region1/mysql.yml
vars/prod-region1/keys.yml
vars/prod-region1/test.yml
vars/stage-region2/mysql.yml
vars/stage-region2/keys.yml
vars/stage-region2/test.yml
vars/local/mysql.yml
vars/local/test.yml";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}