re = /vars\/(prod\S*|stage\S*)\/(mysql|keys).yml/
str = 'vars/prod-region1/mysql.yml
vars/prod-region1/keys.yml
vars/prod-region1/test.yml
vars/stage-region2/mysql.yml
vars/stage-region2/keys.yml
vars/stage-region2/test.yml
vars/local/mysql.yml
vars/local/test.yml'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end