import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*:\\s*$";
final String string = "0\n"
+ "0.0 // less than lower bound\n"
+ "0.19 // fraction part is 2 digits, right '9' is extra\n"
+ "94.11-2.32 // fraction part is 2 digits, right '1' is extra\n"
+ "999.90 // fraction part is 2 digits, '0' is extra\n"
+ "9.0 // should be 9 or 9.1, 9.0 is wrong\n"
+ "1000\n\n"
+ "0.1\n"
+ "1.1\n"
+ "55.5\n"
+ "999.9\n\n"
+ "2.0:2.2\n"
+ ":a\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}