$re = '/^\s*:\s*$/';
$str = '0
0.0 // less than lower bound
0.19 // fraction part is 2 digits, right \'9\' is extra
94.11-2.32 // fraction part is 2 digits, right \'1\' is extra
999.90 // fraction part is 2 digits, \'0\' is extra
9.0 // should be 9 or 9.1, 9.0 is wrong
1000
0.1
1.1
55.5
999.9
2.0:2.2
:a
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);