# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*:\s*$"
test_str = ("0\n"
"0.0 // less than lower bound\n"
"0.19 // fraction part is 2 digits, right '9' is extra\n"
"94.11-2.32 // fraction part is 2 digits, right '1' is extra\n"
"999.90 // fraction part is 2 digits, '0' is extra\n"
"9.0 // should be 9 or 9.1, 9.0 is wrong\n"
"1000\n\n"
"0.1\n"
"1.1\n"
"55.5\n"
"999.9\n\n"
"2.0:2.2\n"
":a\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.