use strict;
my $str = '0
0.0 // less than lower bound
0.19 // fraction part is 2 digits, right \'9\' is extra
94.11-2.32 // fraction part is 2 digits, right \'1\' is extra
999.90 // fraction part is 2 digits, \'0\' is extra
9.0 // should be 9 or 9.1, 9.0 is wrong
1000
0.1
1.1
55.5
999.9
2.0:2.2
:a
';
my $regex = qr/^\s*:\s*$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}