#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:windows|remodeling)(?:\sin\s)?\s*(\w+)(?=\s(?:ny|texas|wa)|)"
Local $sString = "replacement windows in seattle wa" & @CRLF & _
"basement remodeling houston texas" & @CRLF & _
"siding contractor new york ny" & @CRLF & _
"windows in elk grove village"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")