import re
regex = re.compile(r"\b(?:windows|remodeling)(?:\sin\s)?\s*(\w+)(?=\s(?:ny|texas|wa)|)", flags=re.MULTILINE)
test_str = ("replacement windows in seattle wa\n"
"basement remodeling houston texas\n"
"siding contractor new york ny\n"
"windows in elk grove village")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")