import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:windows|remodeling)(?:\\sin\\s)?\\s*(\\w+)(?=\\s(?:ny|texas|wa)|)";
final String string = "replacement windows in seattle wa\n"
+ "basement remodeling houston texas\n"
+ "siding contractor new york ny\n"
+ "windows in elk grove village";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}