using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[Xx]yz(?=[^<>]*<)(?!(<(?:a|span)>(?:.|\n))*</(?:span|a)>)";
string input = @"xyz
Company name nissan and Xyz abc product.
<p>Company name xyz and xyz abc product.</p>
<a href=""xyz""><span>Xyz</span></a>
<a href=""Xyz""><span>xyz</span></a>
<span>xyz</span>
<p>You know Nissan become now <a href=""xyz.com""><span>xyz</span></a> Micra.</p>
You know xyz become now http://www.xyz.com.
<p>Now .xyz. become now www.xyz.com</p>
<p>www.xyz.com</p>
<p>Hello you know Xyz is Now xyz become now www.xyz.com</p>
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}