re = /[Xx]yz(?=[^<>]*<)(?!(<(?:a|span)>(?:.|\n))*<\/(?:span|a)>)/im
str = 'xyz
Company name nissan and Xyz abc product.
<p>Company name xyz and xyz abc product.</p>
<a href="xyz"><span>Xyz</span></a>
<a href="Xyz"><span>xyz</span></a>
<span>xyz</span>
<p>You know Nissan become now <a href="xyz.com"><span>xyz</span></a> Micra.</p>
You know xyz become now http://www.xyz.com.
<p>Now .xyz. become now www.xyz.com</p>
<p>www.xyz.com</p>
<p>Hello you know Xyz is Now xyz become now www.xyz.com</p>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end