# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[Xx]yz(?=[^<>]*<)(?!(<(?:a|span)>(?:.|\n))*</(?:span|a)>)"
test_str = ("xyz\n"
"Company name nissan and Xyz abc product.\n"
"<p>Company name xyz and xyz abc product.</p>\n\n"
"<a href=\"xyz\"><span>Xyz</span></a>\n"
"<a href=\"Xyz\"><span>xyz</span></a>\n"
"<span>xyz</span>\n"
"<p>You know Nissan become now <a href=\"xyz.com\"><span>xyz</span></a> Micra.</p>\n\n"
"You know xyz become now http://www.xyz.com. \n"
"<p>Now .xyz. become now www.xyz.com</p>\n\n\n"
"<p>www.xyz.com</p>\n"
"<p>Hello you know Xyz is Now xyz become now www.xyz.com</p>\n\n")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.