import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[Xx]yz(?=[^<>]*<)(?!(<(?:a|span)>(?:.|\\n))*</(?:span|a)>)";
final String string = "xyz\n"
+ "Company name nissan and Xyz abc product.\n"
+ "<p>Company name xyz and xyz abc product.</p>\n\n"
+ "<a href=\"xyz\"><span>Xyz</span></a>\n"
+ "<a href=\"Xyz\"><span>xyz</span></a>\n"
+ "<span>xyz</span>\n"
+ "<p>You know Nissan become now <a href=\"xyz.com\"><span>xyz</span></a> Micra.</p>\n\n"
+ "You know xyz become now http://www.xyz.com. \n"
+ "<p>Now .xyz. become now www.xyz.com</p>\n\n\n"
+ "<p>www.xyz.com</p>\n"
+ "<p>Hello you know Xyz is Now xyz become now www.xyz.com</p>\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}