# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=src=)"[^" ]*\\/(?=[^\\/"]*\\/)//g;t' <<< "<img width=\"594\" height=\"392\" src=\"/sites/it_kb/SiteAssets/Pages/exploding%20the%20VDI%20vDesktop/VDI3.PNG\" alt=\"\" style=\"margin:5px;width:619px;height:232px\" />"