re = /(?<=src=)"[^" ]*\/(?=[^\/"]*\/)/
str = '<img width="594" height="392" src="/sites/it_kb/SiteAssets/Pages/exploding%20the%20VDI%20vDesktop/VDI3.PNG" alt="" style="margin:5px;width:619px;height:232px" />'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result