$re = '/(?<=src=)"[^" ]*\/(?=[^\/"]*\/)/';
$str = '<img width="594" height="392" src="/sites/it_kb/SiteAssets/Pages/exploding%20the%20VDI%20vDesktop/VDI3.PNG" alt="" style="margin:5px;width:619px;height:232px" />';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;