const regex = /public [A-Za-z\?]* ([A-Za-z0-9]*) .*/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('public [A-Za-z\\?]* ([A-Za-z0-9]*) .*', 'gim')
const str = `
public string AddressLine1 { get; set; }
public string AddressLine2 { get; set; }
public string AddressLine3 { get; set; }
public string AddressLine4 { get; set; }
public string AddressLine5 { get; set; }
public string AddressLine6 { get; set; }
public DateTime? Dob { get; set; }
public string EmailAddress { get; set; }
public string FirstName { get; set; }
public string LastName { get; set; }
public string PostCode { get; set; }
public string PrimaryPhoneNo { get; set; }
public string Title { get; set; }`;
const subst = `$1 = customerDetails.$1,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);