use strict;
my $str = '
public string AddressLine1 { get; set; }
public string AddressLine2 { get; set; }
public string AddressLine3 { get; set; }
public string AddressLine4 { get; set; }
public string AddressLine5 { get; set; }
public string AddressLine6 { get; set; }
public DateTime? Dob { get; set; }
public string EmailAddress { get; set; }
public string FirstName { get; set; }
public string LastName { get; set; }
public string PostCode { get; set; }
public string PrimaryPhoneNo { get; set; }
public string Title { get; set; }';
my $regex = qr/public [A-Za-z\?]* ([A-Za-z0-9]*) .*/imp;
my $subst = '$1 = customerDetails.$1,';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";