// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)public [A-Za-z\?]* ([A-Za-z0-9]*) .*").unwrap();
let string = "
public string AddressLine1 { get; set; }
public string AddressLine2 { get; set; }
public string AddressLine3 { get; set; }
public string AddressLine4 { get; set; }
public string AddressLine5 { get; set; }
public string AddressLine6 { get; set; }
public DateTime? Dob { get; set; }
public string EmailAddress { get; set; }
public string FirstName { get; set; }
public string LastName { get; set; }
public string PostCode { get; set; }
public string PrimaryPhoneNo { get; set; }
public string Title { get; set; }";
let substitution = "$1 = customerDetails.$1,";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}