# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"public [A-Za-z\?]* ([A-Za-z0-9]*) .*"
test_str = (" \n"
" public string AddressLine1 { get; set; }\n\n"
" public string AddressLine2 { get; set; }\n\n"
" public string AddressLine3 { get; set; }\n\n"
" public string AddressLine4 { get; set; }\n\n"
" public string AddressLine5 { get; set; }\n\n"
" public string AddressLine6 { get; set; }\n\n"
" public DateTime? Dob { get; set; }\n\n"
" public string EmailAddress { get; set; }\n\n"
" public string FirstName { get; set; }\n\n"
" public string LastName { get; set; }\n\n"
" public string PostCode { get; set; }\n\n"
" public string PrimaryPhoneNo { get; set; }\n\n"
" public string Title { get; set; }")
subst = "$1 = customerDetails.$1,"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.