$re = '/(<li[^<]*>)([^>]*<\/li>)(?=(?![\s\S]*?<ol[^<]*>)[\s\S]*?<\/ol>)/';
$str = '<ol>
<li>This is a new list</li>
<ol>
<li>Embedded List</li>
<li>Embedded List</li>
</ol>
</ol>';
$subst = "$1 $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;