import re
regex = re.compile(r"(<li[^<]*>)([^>]*<\/li>)(?=(?![\s\S]*?<ol[^<]*>)[\s\S]*?<\/ol>)")
test_str = ("<ol>\n"
" <li>This is a new list</li>\n"
" <ol>\n"
" <li>Embedded List</li>\n"
" <li>Embedded List</li>\n"
" </ol>\n"
" </ol>")
subst = "$1 $2"
result = regex.sub(subst, test_str)
if result:
print(result)