# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\$\{[^}]+?\.([^}.]+)}/$1/g;t' <<< "Patient:
${ss.patient.howard.firstName} ${ss.patient.howard.lastName}
Gender: ${ss.patient.howard.sex}
Birthdate: ${ss.patient.howard.dob}
${ss.patient.howard.addressLine1}
Phone: (801)546-4765"