import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$\\{[^\\}]+?\\.([^\\}.]+)\\}";
final String string = "Patient:\n"
+ "${ss.patient.howard.firstName} ${ss.patient.howard.lastName}\n"
+ "Gender: ${ss.patient.howard.sex}\n"
+ "Birthdate: ${ss.patient.howard.dob}\n"
+ "${ss.patient.howard.addressLine1}\n"
+ "Phone: (801)546-4765";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}