#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\$\{[^}]+?\.([^}.]+)}"
Local $sString = "Patient:" & @CRLF & _
"${ss.patient.howard.firstName} ${ss.patient.howard.lastName}" & @CRLF & _
"Gender: ${ss.patient.howard.sex}" & @CRLF & _
"Birthdate: ${ss.patient.howard.dob}" & @CRLF & _
"${ss.patient.howard.addressLine1}" & @CRLF & _
"Phone: (801)546-4765"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)