re = /\$\{[^}]+?\.([^}.]+)}/
str = 'Patient:
${ss.patient.howard.firstName} ${ss.patient.howard.lastName}
Gender: ${ss.patient.howard.sex}
Birthdate: ${ss.patient.howard.dob}
${ss.patient.howard.addressLine1}
Phone: (801)546-4765'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result