use strict;
my $str = ' (9,\'zxvvgf@housecapades.com\',0,0,1,1,0,1,1),
(10,\'qwer@rogers.co.uk\',1,0,0,1,0,0,1),
(11,\'lorenIpsum@hotmail.com\',0,0,0,1,0,0,1),
(12,\'BarackObama@googlemail.co.uk\',1,0,9,1,1,1,1),
(13,\'DonaldTrump@courtesysupportteam.net\',0,0,9,1,1,1,1),
(15,\'Mcaine@mynet.com\',1,0,9,1,1,1,1),
(16,\'davestra_@hotmail.com\',0,0,0,1,0,0,1),
(17,\'lewisHamilton@carracing.co.uk\',1,0,9,1,1,1,1)';
my $regex = qr/'(.*?\.co\.uk)'/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}