import re
regex = re.compile(r"'(.*?\.co\.uk)'")
test_str = (" (9,'zxvvgf@housecapades.com',0,0,1,1,0,1,1),\n"
" (10,'qwer@rogers.co.uk',1,0,0,1,0,0,1),\n"
" (11,'lorenIpsum@hotmail.com',0,0,0,1,0,0,1),\n"
" (12,'BarackObama@googlemail.co.uk',1,0,9,1,1,1,1),\n"
" (13,'DonaldTrump@courtesysupportteam.net',0,0,9,1,1,1,1),\n"
" (15,'Mcaine@mynet.com',1,0,9,1,1,1,1),\n"
" (16,'davestra_@hotmail.com',0,0,0,1,0,0,1),\n"
" (17,'lewisHamilton@carracing.co.uk',1,0,9,1,1,1,1)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")