#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)<{7}[ ]HEAD[\r\n]{1,2}([\S\s]*?)(?:={7}[\r\n]{1,2}((?:[\S\s]?(?!(>{7}[ ][a-z0-9]{40})))*[\r\n]?)(?:>{7}[ ][a-z0-9]{40}[\r\n]{0,2})?)"
Local $sString = "<<<<<<< HEAD" & @CRLF & _
" Release.AspNetCompiler.VirtualPath = "/agsdasgd"" & @CRLF & _
" Release.AspNetCompiler.PhysicalPath = "Server\PATH\afgdafgd\"" & @CRLF & _
" Release.AspNetCompiler.TargetPath = "PrePATH\to\PATH\afgdafdgPATH\"" & @CRLF & _
"=======" & @CRLF & _
" Release.AspNetCompiler.VirtualPath = "/afdgafdPATH"" & @CRLF & _
" Release.AspNetCompiler.PhysicalPath = "PATH\PATH\PATH\"" & @CRLF & _
" Release.AspNetCompiler.TargetPath = "PATHYPATH\afdgadfg\"" & @CRLF & _
">>>>>>> aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa" & @CRLF & _
"afds" & @CRLF & _
"fgds" & @CRLF & _
"testing" & @CRLF & _
"<<<<<<< HEAD" & @CRLF & _
"kljasdfasfd" & @CRLF & _
"sadfkljasdf" & @CRLF & _
"kdjsfla" & @CRLF & _
"k" & @CRLF & _
"afjdsl" & @CRLF & _
"asfdkljafsdk" & @CRLF & _
"jlfsadkj" & @CRLF & _
"lasfdk" & @CRLF & _
"jl" & @CRLF & _
"=======" & @CRLF & _
"fadsjkl" & @CRLF & _
"fdaskj" & @CRLF & _
"lfdas" & @CRLF & _
"jklfadsk" & @CRLF & _
"ljafdsjkl" & @CRLF & _
"fadsk" & @CRLF & _
"ljafdsk" & @CRLF & _
"jlafdskj" & @CRLF & _
"ladfs" & @CRLF & _
"kjlfdask" & @CRLF & _
"ljfadskj" & @CRLF & _
"ladfsk" & @CRLF & _
"jl" & @CRLF & _
">>>>>>> aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa" & @CRLF & _
"fds" & @CRLF & _
"fads" & @CRLF & _
"afds" & @CRLF & _
"fads" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")