$re = '/<{7}[ ]HEAD[\r\n]{1,2}([\S\s]*?)(?:={7}[\r\n]{1,2}((?:[\S\s]?(?!(>{7}[ ][a-z0-9]{40})))*[\r\n]?)(?:>{7}[ ][a-z0-9]{40}[\r\n]{0,2})?)/x';
$str = '<<<<<<< HEAD
Release.AspNetCompiler.VirtualPath = "/agsdasgd"
Release.AspNetCompiler.PhysicalPath = "Server\\PATH\\afgdafgd\\"
Release.AspNetCompiler.TargetPath = "PrePATH\\to\\PATH\\afgdafdgPATH\\"
=======
Release.AspNetCompiler.VirtualPath = "/afdgafdPATH"
Release.AspNetCompiler.PhysicalPath = "PATH\\PATH\\PATH\\"
Release.AspNetCompiler.TargetPath = "PATHYPATH\\afdgadfg\\"
>>>>>>> aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
afds
fgds
testing
<<<<<<< HEAD
kljasdfasfd
sadfkljasdf
kdjsfla
k
afjdsl
asfdkljafsdk
jlfsadkj
lasfdk
jl
=======
fadsjkl
fdaskj
lfdas
jklfadsk
ljafdsjkl
fadsk
ljafdsk
jlafdskj
ladfs
kjlfdask
ljfadskj
ladfsk
jl
>>>>>>> aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
fds
fads
afds
fads
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);