#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([\|]?[\|]?[ ]?)3193(?:[^\-]*\-){14}([\|]?[\|]?[ ]?)"
Local $sString = "3189, - , - ,8:30 - 10:45, - , - , - , - , - ,8:30 - 12:00,1:30 - 3:45, - , - , - , - || 3193,8:30 - 12:00,1:30 - 5:00, - ,1:30 - 5:00,9:00 - 12:00,1:30 - 5:00, - , - , - , - , - , - , - , -"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")