$re = '/([\|]?[\|]?[ ]?)3193(?:[^\-]*\-){14}([\|]?[\|]?[ ]?)/';
$str = '3189, - , - ,8:30 - 10:45, - , - , - , - , - ,8:30 - 12:00,1:30 - 3:45, - , - , - , - || 3193,8:30 - 12:00,1:30 - 5:00, - ,1:30 - 5:00,9:00 - 12:00,1:30 - 5:00, - , - , - , - , - , - , - , -';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);