import Foundation
let pattern = #"([\|]?[\|]?[ ]?)3193(?:[^\-]*\-){14}([\|]?[\|]?[ ]?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"3189, - , - ,8:30 - 10:45, - , - , - , - , - ,8:30 - 12:00,1:30 - 3:45, - , - , - , - || 3193,8:30 - 12:00,1:30 - 5:00, - ,1:30 - 5:00,9:00 - 12:00,1:30 - 5:00, - , - , - , - , - , - , - , -"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}